# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div(?!>).*?class=\"myClass\".*?>(.*?)<\/div>"
test_str = "<div class=\"test\"></div><div></div><div id=\"foo\" class=\"myClass\" title=\"bar\">Works</div>"
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.