# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=,)(?=[^,]*$)/ MS/gm;t' <<< "123 Main Street, West Street, Townsville, 210-319
123 Main Street, Townsville, 210-319"