import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=,)(?=[^,]*$)";
final String string = "123 Main Street, West Street, Townsville, 210-319\n"
+ "123 Main Street, Townsville, 210-319";
final String subst = " MS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}