$re = '/(?<=,)(?=[^,]*$)/m';
$str = '123 Main Street, West Street, Townsville, 210-319
123 Main Street, Townsville, 210-319';
$subst = " MS";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;