#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>(.{1,24})(?= |$))(?: (.{1,30}+))?$"
Local $sString = "1 Apple Park Way. Cupertino, CA 95014" & @CRLF & _
"" & @CRLF & _
"1600 Amphitheatre Parkway Mountain View, CA 94043" & @CRLF & _
"" & @CRLF & _
"123456789012345678901234567890123456789012345678901234" & @CRLF & _
"" & @CRLF & _
"123456789012345678901234" & @CRLF & _
"" & @CRLF & _
"12345678901234 123456789012345678901234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")