$re = '/^(?>(.{1,24})(?= |$))(?: (.{1,30}+))?$/m';
$str = '1 Apple Park Way. Cupertino, CA 95014
1600 Amphitheatre Parkway Mountain View, CA 94043
123456789012345678901234567890123456789012345678901234
123456789012345678901234
12345678901234 123456789012345678901234567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);