import re
regex = re.compile(r"^(?>(.{1,24})(?= |$))(?: (.{1,30}+))?$", flags=re.MULTILINE)
test_str = ("1 Apple Park Way. Cupertino, CA 95014\n\n"
"1600 Amphitheatre Parkway Mountain View, CA 94043\n\n"
"123456789012345678901234567890123456789012345678901234\n\n"
"123456789012345678901234\n\n"
"12345678901234 123456789012345678901234567890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")