#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(?!#)|#"
Local $sString = "#fox #fo x #fox # fox # fox"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)