use strict;
my $str = '#fox #fo x #fox # fox # fox';
my $regex = qr/\s(?!#)|#/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";