$re = '/\s(?!#)|#/';
$str = '#fox #fo x #fox # fox # fox';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;