#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(http(s)?:\/\/)((www\.)?[steamcommunity]+\.)+[\w-]+(\/profiles\/7656[0-9]{13}\/?)$"
Local $sString = "https://steamcommunity.com/profiles/76561197963701815" & @CRLF & _
"http://steamcommunity.com/profiles/76561197963701815" & @CRLF & _
"https://www.steamcommunity.com/profiles/76561197963721411/" & @CRLF & _
"http://www.steamcommunity.com/profiles/76561197863721421/" & @CRLF & _
"http://steamcommunity.com/id/AyyDrWhat/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")