use strict;
my $str = 'https://steamcommunity.com/profiles/76561197963701815
http://steamcommunity.com/profiles/76561197963701815
https://www.steamcommunity.com/profiles/76561197963721411/
http://www.steamcommunity.com/profiles/76561197863721421/
http://steamcommunity.com/id/AyyDrWhat/';
my $regex = qr/^(http(s)?:\/\/)((www\.)?[steamcommunity]+\.)+[\w-]+(\/profiles\/7656[0-9]{13}\/?)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}