import re
regex = re.compile(r"^(http(s)?:\/\/)((www\.)?[steamcommunity]+\.)+[\w-]+(\/profiles\/7656[0-9]{13}\/?)$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://steamcommunity.com/profiles/76561197963701815\n"
"http://steamcommunity.com/profiles/76561197963701815\n"
"https://www.steamcommunity.com/profiles/76561197963721411/\n"
"http://www.steamcommunity.com/profiles/76561197863721421/\n"
"http://steamcommunity.com/id/AyyDrWhat/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")