#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a\s*(?:href=[\'"]([^\'"]+)[\'"])?\s*(?:title=[\'"]([^\'"]+)[\'"])?.*?>((?:(?!<\/a>).)*)<\/a>"
Local $sString = "<a href="/test1" title="da">test</a> " & @CRLF & _
"<a href="//stackoverflow.com">current community</a>" & @CRLF & _
"dwadwad<a href="/test2" title="adwa">test2</a>213213" & @CRLF & _
"<a href="/test2" title="adwa">test2</a>ed<a href="/test3">test2</a>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")