use strict;
my $str = '<a href="/test1" title="da">test</a>
<a href="//stackoverflow.com">current community</a>
dwadwad<a href="/test2" title="adwa">test2</a>213213
<a href="/test2" title="adwa">test2</a>ed<a href="/test3">test2</a>
';
my $regex = qr/<a\s*(?:href=[\'"]([^\'"]+)[\'"])?\s*(?:title=[\'"]([^\'"]+)[\'"])?.*?>((?:(?!<\/a>).)*)<\/a>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}