#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^.*(?:EVENTS:OB:\s(?:RECORDS\snot|RECORDS\sthat|Unprocessed))(?!.*0\.0$).*$"
Local $sString = "EVENTS:OB: Records not updated to status" & @CRLF & _
"EVENTS:OB: Records that were pending OR to be processed for yester day. " & @CRLF & _
"EVENTS:OB: Unprocessed records older than hour. " & @CRLF & _
"RENAS:OB:BOX: Unprocessed records older than hour. " & @CRLF & _
"RENAS:MOSS Pending " & @CRLF & _
"RENAS:TIGNET Pending " & @CRLF & _
"RENAS:OB:SI: Unprocessed records older than hour. " & @CRLF & _
"RENAS:OB:GC: Unprocessed records older than hour. " & @CRLF & _
"RENAS:RENAS:Count of pending message to process. " & @CRLF & _
"RENAS:OB:10+2_Status: Unprocessed records older than hour." & @CRLF & _
"RENAS:RENAS_10+2:Unprocessed records in RENAS 10+2" & @CRLF & _
"RENAS:RENAS ACH:Count of pending message to process to FV." & @CRLF & _
"RENAS:CheckNow:Count of pending message to process to FV" & @CRLF & _
"RENAS:OB:GB: Unprocessed records older than hour." & @CRLF & _
"RENAS:RENAS: UN Processed records by MIXX for RENAS INSTRUCTONS " & @CRLF & _
"RENAS:RENAS: UN Processed records by MIXX for RENAS Break Bulk " & @CRLF & _
"RENAS:RENAS: UN Processed records by MIXX for RENAS " & @CRLF & _
"RENAS:OB:DOM:Unprocessed count of records older than hour." & @CRLF & _
"RENAS:OB:DOM:Failed records in the database for previous date." & @CRLF & _
"RENAS:OB:SI:Records that were pending to be processed for the previous day."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")