import Foundation
let pattern = #"^.*(?:EVENTS:OB:\s(?:RECORDS\snot|RECORDS\sthat|Unprocessed))(?!.*0\.0$).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
EVENTS:OB: Records not updated to status
EVENTS:OB: Records that were pending OR to be processed for yester day.
EVENTS:OB: Unprocessed records older than hour.
RENAS:OB:BOX: Unprocessed records older than hour.
RENAS:MOSS Pending
RENAS:TIGNET Pending
RENAS:OB:SI: Unprocessed records older than hour.
RENAS:OB:GC: Unprocessed records older than hour.
RENAS:RENAS:Count of pending message to process.
RENAS:OB:10+2_Status: Unprocessed records older than hour.
RENAS:RENAS_10+2:Unprocessed records in RENAS 10+2
RENAS:RENAS ACH:Count of pending message to process to FV.
RENAS:CheckNow:Count of pending message to process to FV
RENAS:OB:GB: Unprocessed records older than hour.
RENAS:RENAS: UN Processed records by MIXX for RENAS INSTRUCTONS
RENAS:RENAS: UN Processed records by MIXX for RENAS Break Bulk
RENAS:RENAS: UN Processed records by MIXX for RENAS
RENAS:OB:DOM:Unprocessed count of records older than hour.
RENAS:OB:DOM:Failed records in the database for previous date.
RENAS:OB:SI:Records that were pending to be processed for the previous day.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)