import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?:EVENTS:OB:\\s(?:RECORDS\\snot|RECORDS\\sthat|Unprocessed))(?!.*0\\.0$).*$";
final String string = "EVENTS:OB: Records not updated to status\n"
+ "EVENTS:OB: Records that were pending OR to be processed for yester day. \n"
+ "EVENTS:OB: Unprocessed records older than hour. \n"
+ "RENAS:OB:BOX: Unprocessed records older than hour. \n"
+ "RENAS:MOSS Pending \n"
+ "RENAS:TIGNET Pending \n"
+ "RENAS:OB:SI: Unprocessed records older than hour. \n"
+ "RENAS:OB:GC: Unprocessed records older than hour. \n"
+ "RENAS:RENAS:Count of pending message to process. \n"
+ "RENAS:OB:10+2_Status: Unprocessed records older than hour.\n"
+ "RENAS:RENAS_10+2:Unprocessed records in RENAS 10+2\n"
+ "RENAS:RENAS ACH:Count of pending message to process to FV.\n"
+ "RENAS:CheckNow:Count of pending message to process to FV\n"
+ "RENAS:OB:GB: Unprocessed records older than hour.\n"
+ "RENAS:RENAS: UN Processed records by MIXX for RENAS INSTRUCTONS \n"
+ "RENAS:RENAS: UN Processed records by MIXX for RENAS Break Bulk \n"
+ "RENAS:RENAS: UN Processed records by MIXX for RENAS \n"
+ "RENAS:OB:DOM:Unprocessed count of records older than hour.\n"
+ "RENAS:OB:DOM:Failed records in the database for previous date.\n"
+ "RENAS:OB:SI:Records that were pending to be processed for the previous day.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}