using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![+\w+])[^+][\w\W]+?\s";
string substitution = @"";
string input = @"+Z XA( 0,1,6,22,26,33,34,35,36,25,24) +DD +I +M >x1 >bdz +A";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}