const regex = new RegExp('(?<![+\\w+])[^+][\\w\\W]+?\\s', 'g')
const str = `+Z XA( 0,1,6,22,26,33,34,35,36,25,24) +DD +I +M >x1 >bdz +A`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);