import Foundation
let pattern = #"(?<![+\w+])[^+][\w\W]+?\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+Z XA( 0,1,6,22,26,33,34,35,36,25,24) +DD +I +M >x1 >bdz +A"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)