package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\\\emph{(.*?)}`)
var str = `some text in \\emph{italics} and some \\emph{more italics} and ...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}