re = /\\\\emph{(.*?)}/
str = 'some text in \\\\emph{italics} and some \\\\emph{more italics} and ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end