#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<tr bgcolor="#EAF2FA">\s*<td colspan="2">\s*<font style="font-family:sans-serif;font-size:12px"><strong>Prénom \*<\/strong><\/font>\s*<\/td>\s*<\/tr>\s*<tr bgcolor="#FFFFFF">\s*<td width="20"> <\/td>\s*<td>\s*<font style="font-family:sans-serif;font-size:12px">(?<Prenom>.*)<\/font>"
Local $sString = "<tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Prénom *</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">Nicolas</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Nom *</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">NICOLAS</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Email *</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><a href="mailto:nicolas.rauber.ea@gmail.com" target="_blank">nicolas.rauber.ea@gmail.com</a></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Téléphone</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">123456431134455</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="2" style="font-size:14px;font-weight:bold;background-color:#eee;border-bottom:1px solid #dfdfdf;padding:7px 7px">Où se trouve le bien à estimer ?</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Adresse *</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">ADRESS</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Code postal *</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">ZIP</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Ville *</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">CITY</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#EAF2FA">" & @CRLF & _
" <td colspan="2">" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px"><strong>Votre message</strong></font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr bgcolor="#FFFFFF">" & @CRLF & _
" <td width="20"> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <font style="font-family:sans-serif;font-size:12px">MESSAGE</font>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")