# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<tr bgcolor=\"#EAF2FA\">\s*<td colspan=\"2\">\s*<font style=\"font-family:sans-serif;font-size:12px\"><strong>Prénom \*<\/strong><\/font>\s*<\/td>\s*<\/tr>\s*<tr bgcolor=\"#FFFFFF\">\s*<td width=\"20\"> <\/td>\s*<td>\s*<font style=\"font-family:sans-serif;font-size:12px\">(?<Prenom>.*)<\/font>"
test_str = ("<tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Prénom *</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">Nicolas</font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Nom *</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">NICOLAS</font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Email *</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><a href=\"mailto:nicolas.rauber.ea@gmail.com\" target=\"_blank\">nicolas.rauber.ea@gmail.com</a></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Téléphone</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">123456431134455</font>\n"
" </td>\n"
" </tr>\n"
" <tr>\n"
" <td colspan=\"2\" style=\"font-size:14px;font-weight:bold;background-color:#eee;border-bottom:1px solid #dfdfdf;padding:7px 7px\">Où se trouve le bien à estimer ?</td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Adresse *</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">ADRESS</font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Code postal *</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">ZIP</font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Ville *</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">CITY</font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#EAF2FA\">\n"
" <td colspan=\"2\">\n"
" <font style=\"font-family:sans-serif;font-size:12px\"><strong>Votre message</strong></font>\n"
" </td>\n"
" </tr>\n"
" <tr bgcolor=\"#FFFFFF\">\n"
" <td width=\"20\"> </td>\n"
" <td>\n"
" <font style=\"font-family:sans-serif;font-size:12px\">MESSAGE</font>\n"
" </td>\n"
" </tr>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.