import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\.)\\b0(?:\\.0+)?(?!\\.)\\b";
final String string = "0\n"
+ "0.0\n"
+ "0.0000\n"
+ "10\n"
+ "10.0000\n"
+ "0.122\n"
+ "25.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}