$re = '/(?<!\.)\b0(?:\.0+)?(?!\.)\b/m';
$str = '0
0.0
0.0000
10
10.0000
0.122
25.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);