const regex = /-?0*\.0+\b|\.0+(?=,|$)|(?:^|(?<=,))(-)?0+(?=\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?0*\\.0+\\b|\\.0+(?=,|$)|(?:^|(?<=,))(-)?0+(?=\\.)', 'gm')
const str = `2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);