re = /-?0*\.0+\b|\.0+(?=,|$)|(?:^|(?<=,))(-)?0+(?=\.)/m
str = '2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result