import re
regex = re.compile(r"-?0*\.0+\b|\.0+(?=,|$)|(?:^|(?<=,))(-)?0+(?=\.)", flags=re.MULTILINE)
test_str = "2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)