package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+(?:\s[a-zA-Z]+)*$`)
var str = `John
John Smith
2131321
A very long name with many spaces`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}