re = /^[a-zA-Z]+(?:\s[a-zA-Z]+)*$/m
str = 'John
John Smith
2131321
A very long name with many spaces'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end