$re = '/^[a-zA-Z]+(?:\s[a-zA-Z]+)*$/m';
$str = 'John
John Smith
2131321
A very long name with many spaces';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);