#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s]+\s[^\s]+"
Local $sString = "Monika Olah Richárd Bai" & @CRLF & _
"Like · Reply · March 24 at 4:45pm" & @CRLF & _
"" & @CRLF & _
"Kecskés Dóra Edina Molnar Attila" & @CRLF & _
"Like · Reply · March 24 at 4:16pm" & @CRLF & _
"" & @CRLF & _
"Manole Ioana Dana Marinescu" & @CRLF & _
"Like · Reply · 2 · March 24 at 5:09pm" & @CRLF & _
"" & @CRLF & _
"Norbert Kosa Sinko Bela" & @CRLF & _
"Like · Reply · 1 · March 28 at 9:37am" & @CRLF & _
"" & @CRLF & _
"AsiYe Asy KeJal SeRna" & @CRLF & _
"Like · Reply · 1 · March 27 at 4:59pm" & @CRLF & _
"" & @CRLF & _
"Banu Razvan Ana Banu" & @CRLF & _
"Like · Reply · 1 · March 26 at 11:40pm" & @CRLF & _
"" & @CRLF & _
"Timeia Denysa Batcau Denisa" & @CRLF & _
"Like · Reply · 1 · March 26 at 11:36pm" & @CRLF & _
"" & @CRLF & _
"Cristina Visalon Eugen Comanescu" & @CRLF & _
"Like · Reply · 1 · March 26 at 11:21pm" & @CRLF & _
"" & @CRLF & _
"Irina Paun Paula Cristea" & @CRLF & _
"Like · Reply · 1 · March 26 at 11:31am" & @CRLF & _
"" & @CRLF & _
"Oneth Ciprian Onet Daniela Carmen" & @CRLF & _
"Like · Reply · 1 · March 26 at 12:46am" & @CRLF & _
"" & @CRLF & _
"Sorina Radulescu Tatiana Sorina" & @CRLF & _
"Like · Reply · 1 · March 25 at 11:59pm" & @CRLF & _
"" & @CRLF & _
"Neculay Neculayp Caty Catyp" & @CRLF & _
"Like · Reply · 1 · March 25 at 4:01pm" & @CRLF & _
"" & @CRLF & _
"Lavinia Popescu Lapadat Liviu" & @CRLF & _
"Like · Reply · 1 · March 25 at 12:51pm" & @CRLF & _
"" & @CRLF & _
"Georgeta Pintilie Octavian Pintilie" & @CRLF & _
"Like · Reply · 1 · March 25 at 12:30pm" & @CRLF & _
"" & @CRLF & _
"Elena Petrescu Victor Petrescu" & @CRLF & _
"Like · Reply · 1 · March 25 at 12:29pm" & @CRLF & _
"" & @CRLF & _
"Doina Paraschiv Petre Paraschiv" & @CRLF & _
"Like · Reply · 1 · March 25 at 12:27pm" & @CRLF & _
"" & @CRLF & _
"Adrian Ovreiu Ioana Ovreiu" & @CRLF & _
"Like · Reply · 1 · March 25 at 12:26pm" & @CRLF & _
"" & @CRLF & _
"Stan Papusa Crax Prax" & @CRLF & _
"Like · Reply · 1 · March 25 at 11:20am" & @CRLF & _
"" & @CRLF & _
"Cornelia Ionescu Sorin Soury" & @CRLF & _
"Like · Reply · 1 · March 25 at 10:45am" & @CRLF & _
"" & @CRLF & _
"Daniel Filigeanu Prejmerean Anita" & @CRLF & _
"Like · Reply · 1 · March 25 at 10:44am" & @CRLF & _
"" & @CRLF & _
"Nicolae Georgiana Licuta Stan" & @CRLF & _
"Like · Reply · 1 · March 25 at 9:23am" & @CRLF & _
"" & @CRLF & _
"Ramo Maryam Gabriela Andrei" & @CRLF & _
"Like · Reply · 1 · March 25 at 9:19am" & @CRLF & _
"" & @CRLF & _
"Dana Daniela Lucica Lazar" & @CRLF & _
"Like · Reply · 1 · March 25 at 1:11am" & @CRLF & _
"" & @CRLF & _
"Lucica Lazar Paun Dorin Petru" & @CRLF & _
"Like · Reply · 1 · March 25 at 12:40am" & @CRLF & _
"" & @CRLF & _
"Cristian MurguleÈ› Narcis Gabriel" & @CRLF & _
"Like · Reply · 1 · March 24 at 11:15pm" & @CRLF & _
"" & @CRLF & _
"Rodica Bucur Ionut Richard G" & @CRLF & _
"Like · Reply · 1 · March 24 at 10:53pm" & @CRLF & _
"" & @CRLF & _
"Clavi Mpo Elena Lenti" & @CRLF & _
"Like · Reply · 1 · March 24 at 9:57pm" & @CRLF & _
"" & @CRLF & _
"Flory Florina Adriana Eco" & @CRLF & _
"Like · Reply · 1 · March 24 at 9:01pm" & @CRLF & _
"" & @CRLF & _
"Strempel Henrietta Norbert Ciato" & @CRLF & _
"Like · Reply · 1 · March 24 at 8:31pm" & @CRLF & _
"" & @CRLF & _
"Mihai Marele Bfx Bufu" & @CRLF & _
"Like · Reply · 1 · March 24 at 7:11pm" & @CRLF & _
"" & @CRLF & _
"Mariana Cioranu Petrica Cioranu" & @CRLF & _
"Like · Reply · 1 · March 24 at 6:02pm" & @CRLF & _
"" & @CRLF & _
"Dragusan Tudorel Elena Elena" & @CRLF & _
"Like · Reply · 1 · March 24 at 5:32pm" & @CRLF & _
"" & @CRLF & _
"Selegean Nicoleta Porumbei Albi Selegean" & @CRLF & _
"Like · Reply · 1 · March 24 at 5:12pm" & @CRLF & _
"" & @CRLF & _
"Monika Erzsebet Tamas Szabo" & @CRLF & _
"Like · Reply · March 31 at 11:56pm" & @CRLF & _
"" & @CRLF & _
"Ana Maria Goia Dan Goia" & @CRLF & _
"Like · Reply · March 31 at 7:34pm" & @CRLF & _
"" & @CRLF & _
"Alexandru Gulie anka anca" & @CRLF & _
"Like · Reply · March 30 at 12:58am" & @CRLF & _
"" & @CRLF & _
"Maria Corodescu Popp Costel Dan Corodescu" & @CRLF & _
"Like · Reply · March 29 at 11:27pm" & @CRLF & _
"" & @CRLF & _
"Anduta Si Maruta Vali Vali" & @CRLF & _
"Like · Reply · March 29 at 7:59pm" & @CRLF & _
"" & @CRLF & _
"Petruta Mire Ella Trancan Stefania" & @CRLF & _
"Like · Reply · March 29 at 9:28am" & @CRLF & _
"" & @CRLF & _
"Diana Uricu Razvan Gulie" & @CRLF & _
"Like · Reply · March 29 at 3:02am" & @CRLF & _
"" & @CRLF & _
"Preda Nicoleta Alina Mary Laurentiu" & @CRLF & _
"Like · Reply · March 29 at 12:56am" & @CRLF & _
"" & @CRLF & _
"Gabriela Vasilescu Bily Moky" & @CRLF & _
"Like · Reply · March 28 at 9:19pm" & @CRLF & _
"" & @CRLF & _
"Sinko Bela Norbert Kosa" & @CRLF & _
"Like · Reply · March 28 at 8:05pm" & @CRLF & _
"" & @CRLF & _
"Ioan Bors Stelian Gheorghe" & @CRLF & _
"Like · Reply · March 28 at 7:54pm" & @CRLF & _
"" & @CRLF & _
"Moni Elena Eftaliea Mara" & @CRLF & _
"Like · Reply · March 28 at 5:46pm" & @CRLF & _
"" & @CRLF & _
"Nella Ella Anca Cristina" & @CRLF & _
"Like · Reply · March 28 at 3:00pm" & @CRLF & _
"" & @CRLF & _
"Dorina Balteanu Bogdan Sabangeanu" & @CRLF & _
"Like · Reply · March 28 at 2:59pm" & @CRLF & _
"" & @CRLF & _
"Berinde Vladut Vlad Berinde" & @CRLF & _
"Like · Reply · March 28 at 1:35pm" & @CRLF & _
"" & @CRLF & _
"Iosif Stoian Florentina Flory" & @CRLF & _
"Like · Reply · March 28 at 10:17am" & @CRLF & _
"" & @CRLF & _
"Iulianna Sabo Denisa Bui" & @CRLF & _
"Like · Reply · March 28 at 9:31am" & @CRLF & _
"" & @CRLF & _
"Bleotu Macrina Bleotu Gheorghe" & @CRLF & _
"Like · Reply · March 28 at 9:10am" & @CRLF & _
"" & @CRLF & _
"Ion Cretu Dumitrache Cami Dumitrache" & @CRLF & _
"Like · Reply · March 28 at 1:27am" & @CRLF & _
"" & @CRLF & _
"Carmen Ionela Radian Nicolae" & @CRLF & _
"Like · Reply · March 28 at 1:06am" & @CRLF & _
"" & @CRLF & _
"Cristian Sorin Carmen-Ionela Nicolae" & @CRLF & _
"Like · Reply · March 28 at 12:54am" & @CRLF & _
"" & @CRLF & _
"Cami Dumitrache Dumy Nick" & @CRLF & _
"Like · Reply · March 28 at 12:47am" & @CRLF & _
"" & @CRLF & _
"Nicolae Cristi Crina Toitan" & @CRLF & _
"Like · Reply · March 28 at 12:41am" & @CRLF & _
"" & @CRLF & _
"Nutu Marius Carmen Ionela" & @CRLF & _
"Like · Reply · March 28 at 12:34am" & @CRLF & _
"" & @CRLF & _
"Ile Ilenutza Dan F. Dan" & @CRLF & _
"Like · Reply · March 28 at 12:24am" & @CRLF & _
"" & @CRLF & _
"Marin Nicolae Ioana Nicolae" & @CRLF & _
"Like · Reply · March 28 at 12:21am" & @CRLF & _
"" & @CRLF & _
"Ioana Nicolae Marin Nicolae" & @CRLF & _
"Like · Reply · March 28 at 12:16am" & @CRLF & _
"" & @CRLF & _
"Dumy Nick Cami Dumitrache" & @CRLF & _
"Like · Reply · March 28 at 12:11am" & @CRLF & _
"" & @CRLF & _
"Carmen Nicolae Radian Nicolae" & @CRLF & _
"Like · Reply · March 28 at 12:05am" & @CRLF & _
"" & @CRLF & _
"Marina Cioceanu Liviu Moise" & @CRLF & _
"Like · Reply · March 28 at 12:04am" & @CRLF & _
"" & @CRLF & _
"Ella Ellena Catalin Cozma" & @CRLF & _
"Like · Reply · March 27 at 11:59pm" & @CRLF & _
"" & @CRLF & _
"Mircea Mircea Geta Geta" & @CRLF & _
"Like · Reply · March 27 at 11:52pm" & @CRLF & _
"" & @CRLF & _
"Radian Nicolae Carmen-Ionela Nicolae" & @CRLF & _
"Like · Reply · March 27 at 11:49pm" & @CRLF & _
"" & @CRLF & _
"Emil Hossu Mihaela Nistor" & @CRLF & _
"Like · Reply · March 27 at 11:46pm" & @CRLF & _
"" & @CRLF & _
"Geta Geta Mircea Mircea" & @CRLF & _
"Like · Reply · March 27 at 11:32pm" & @CRLF & _
"" & @CRLF & _
"Fish Dan Paula Gabriela" & @CRLF & _
"Like · Reply · March 27 at 11:26pm" & @CRLF & _
"" & @CRLF & _
"Ungurean Mihai Maria Ungurean" & @CRLF & _
"Like · Reply · March 27 at 11:16pm" & @CRLF & _
"" & @CRLF & _
"Doina Ana Butman Gheorghiu Paul" & @CRLF & _
"Like · Reply · March 27 at 11:09pm" & @CRLF & _
"" & @CRLF & _
"Florin Hossu Octavia Durus," & @CRLF & _
"Like · Reply · March 27 at 10:48pm" & @CRLF & _
"" & @CRLF & _
"Victor Zota Rose Marya" & @CRLF & _
"Like · Reply · March 27 at 10:47pm" & @CRLF & _
"" & @CRLF & _
"Ileana Lala Catalin Cozma" & @CRLF & _
"Like · Reply · March 27 at 10:40pm" & @CRLF & _
"" & @CRLF & _
"Petrina Mani Eva Darla" & @CRLF & _
"Like · Reply · March 27 at 10:39pm" & @CRLF & _
"" & @CRLF & _
"Tiberiu Petrica Veronik Ungurean" & @CRLF & _
"Like · Reply · March 27 at 10:24pm" & @CRLF & _
"" & @CRLF & _
"Melinceanu Adrian Tea Ada Hari Ioakeimidis" & @CRLF & _
"Like · Reply · March 27 at 10:20pm" & @CRLF & _
"" & @CRLF & _
"Tea Ada Hari Ioakeimidis Melinceanu Adrian" & @CRLF & _
"Like · Reply · March 27 at 10:18pm" & @CRLF & _
"" & @CRLF & _
"Elena Maria Veronik Ungurean" & @CRLF & _
"Like · Reply · March 27 at 10:09pm" & @CRLF & _
"" & @CRLF & _
"Mara Pia Giorgiana Gio" & @CRLF & _
"Like · Reply · March 27 at 10:02pm" & @CRLF & _
"" & @CRLF & _
"Ioana Alexandrescu Ion Oprea" & @CRLF & _
"Like · Reply · March 27 at 9:56pm" & @CRLF & _
"" & @CRLF & _
"Adriana Lautarescu Ungureanu Gabriela" & @CRLF & _
"Like · Reply · March 27 at 9:53pm" & @CRLF & _
"" & @CRLF & _
"Catalin Cozma Ileana Lala" & @CRLF & _
"Like · Reply · March 27 at 9:49pm" & @CRLF & _
"" & @CRLF & _
"Steluta Norocoasa Miti Miky" & @CRLF & _
"Like · Reply · March 27 at 9:43pm" & @CRLF & _
"" & @CRLF & _
"Ion Oprea Ioana Alexandrescu" & @CRLF & _
"Like · Reply · March 27 at 9:42pm" & @CRLF & _
"" & @CRLF & _
"Skill Zoor Mihai Raliu" & @CRLF & _
"Like · Reply · March 27 at 9:39pm" & @CRLF & _
"" & @CRLF & _
"Dragos Victor Rose Marya" & @CRLF & _
"Like · Reply · March 27 at 9:17pm" & @CRLF & _
"" & @CRLF & _
"Ioan C. Ioan Daff Dan" & @CRLF & _
"Like · Reply · March 27 at 9:11pm" & @CRLF & _
"" & @CRLF & _
"Antonio Bogdan Cioroiu Flori Mimi" & @CRLF & _
"Like · Reply · March 27 at 9:11pm" & @CRLF & _
"" & @CRLF & _
"Stredie Lydia Mogos Rusalina" & @CRLF & _
"Like · Reply · March 27 at 9:07pm" & @CRLF & _
"" & @CRLF & _
"Flory Maddy Alex Cîrstocea" & @CRLF & _
"Like · Reply · March 27 at 9:04pm" & @CRLF & _
"" & @CRLF & _
"Mariana Baroiu Antonio Bogdan" & @CRLF & _
"Like · Reply · March 27 at 8:55pm" & @CRLF & _
"" & @CRLF & _
"Dany Grasu Raisa Georgiana" & @CRLF & _
"Like · Reply · March 27 at 8:48pm" & @CRLF & _
"" & @CRLF & _
"Ella Dan Adriana Chereches" & @CRLF & _
"Like · Reply · March 27 at 8:41pm" & @CRLF & _
"" & @CRLF & _
"Rose Marya Dragos Victor" & @CRLF & _
"Like · Reply · March 27 at 8:19pm" & @CRLF & _
"" & @CRLF & _
"Veronik Ungurean Tiberiu Petrica" & @CRLF & _
"Like · Reply · March 27 at 7:57pm" & @CRLF & _
"" & @CRLF & _
"Giorgiana Gio Mara Pia" & @CRLF & _
"Like · Reply · March 27 at 7:43pm" & @CRLF & _
"" & @CRLF & _
"Maria Ille Mircea Mircea" & @CRLF & _
"Like · Reply · March 27 at 7:24pm" & @CRLF & _
"" & @CRLF & _
"Ungureanu Gabriela Adriana Lautarescu" & @CRLF & _
"Like · Reply · March 27 at 6:40pm" & @CRLF & _
"" & @CRLF & _
"Mada Madalynutza Madalina Caty Catyp" & @CRLF & _
"Like · Reply · March 27 at 5:56pm" & @CRLF & _
"" & @CRLF & _
"Iliana Mihaela Ionut Cretu" & @CRLF & _
"Like · Reply · March 27 at 4:59pm · Edited" & @CRLF & _
"" & @CRLF & _
"Dragos Zota Marioara Zota" & @CRLF & _
"Like · Reply · March 27 at 4:52pm" & @CRLF & _
"" & @CRLF & _
"Gela Geluta Stefan Stefan" & @CRLF & _
"Like · Reply · March 27 at 4:19pm" & @CRLF & _
"" & @CRLF & _
"Mada Madutza Bogdan Bobo" & @CRLF & _
"Like · Reply · March 27 at 4:08pm" & @CRLF & _
"" & @CRLF & _
"Toni Pre Mona Simu" & @CRLF & _
"Like · Reply · March 27 at 4:03pm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")