import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s]+\\s[^\\s]+";
final String string = "Monika Olah Richárd Bai\n"
+ "Like · Reply · March 24 at 4:45pm\n\n"
+ "Kecskés Dóra Edina Molnar Attila\n"
+ "Like · Reply · March 24 at 4:16pm\n\n"
+ "Manole Ioana Dana Marinescu\n"
+ "Like · Reply · 2 · March 24 at 5:09pm\n\n"
+ "Norbert Kosa Sinko Bela\n"
+ "Like · Reply · 1 · March 28 at 9:37am\n\n"
+ "AsiYe Asy KeJal SeRna\n"
+ "Like · Reply · 1 · March 27 at 4:59pm\n\n"
+ "Banu Razvan Ana Banu\n"
+ "Like · Reply · 1 · March 26 at 11:40pm\n\n"
+ "Timeia Denysa Batcau Denisa\n"
+ "Like · Reply · 1 · March 26 at 11:36pm\n\n"
+ "Cristina Visalon Eugen Comanescu\n"
+ "Like · Reply · 1 · March 26 at 11:21pm\n\n"
+ "Irina Paun Paula Cristea\n"
+ "Like · Reply · 1 · March 26 at 11:31am\n\n"
+ "Oneth Ciprian Onet Daniela Carmen\n"
+ "Like · Reply · 1 · March 26 at 12:46am\n\n"
+ "Sorina Radulescu Tatiana Sorina\n"
+ "Like · Reply · 1 · March 25 at 11:59pm\n\n"
+ "Neculay Neculayp Caty Catyp\n"
+ "Like · Reply · 1 · March 25 at 4:01pm\n\n"
+ "Lavinia Popescu Lapadat Liviu\n"
+ "Like · Reply · 1 · March 25 at 12:51pm\n\n"
+ "Georgeta Pintilie Octavian Pintilie\n"
+ "Like · Reply · 1 · March 25 at 12:30pm\n\n"
+ "Elena Petrescu Victor Petrescu\n"
+ "Like · Reply · 1 · March 25 at 12:29pm\n\n"
+ "Doina Paraschiv Petre Paraschiv\n"
+ "Like · Reply · 1 · March 25 at 12:27pm\n\n"
+ "Adrian Ovreiu Ioana Ovreiu\n"
+ "Like · Reply · 1 · March 25 at 12:26pm\n\n"
+ "Stan Papusa Crax Prax\n"
+ "Like · Reply · 1 · March 25 at 11:20am\n\n"
+ "Cornelia Ionescu Sorin Soury\n"
+ "Like · Reply · 1 · March 25 at 10:45am\n\n"
+ "Daniel Filigeanu Prejmerean Anita\n"
+ "Like · Reply · 1 · March 25 at 10:44am\n\n"
+ "Nicolae Georgiana Licuta Stan\n"
+ "Like · Reply · 1 · March 25 at 9:23am\n\n"
+ "Ramo Maryam Gabriela Andrei\n"
+ "Like · Reply · 1 · March 25 at 9:19am\n\n"
+ "Dana Daniela Lucica Lazar\n"
+ "Like · Reply · 1 · March 25 at 1:11am\n\n"
+ "Lucica Lazar Paun Dorin Petru\n"
+ "Like · Reply · 1 · March 25 at 12:40am\n\n"
+ "Cristian MurguleÈ› Narcis Gabriel\n"
+ "Like · Reply · 1 · March 24 at 11:15pm\n\n"
+ "Rodica Bucur Ionut Richard G\n"
+ "Like · Reply · 1 · March 24 at 10:53pm\n\n"
+ "Clavi Mpo Elena Lenti\n"
+ "Like · Reply · 1 · March 24 at 9:57pm\n\n"
+ "Flory Florina Adriana Eco\n"
+ "Like · Reply · 1 · March 24 at 9:01pm\n\n"
+ "Strempel Henrietta Norbert Ciato\n"
+ "Like · Reply · 1 · March 24 at 8:31pm\n\n"
+ "Mihai Marele Bfx Bufu\n"
+ "Like · Reply · 1 · March 24 at 7:11pm\n\n"
+ "Mariana Cioranu Petrica Cioranu\n"
+ "Like · Reply · 1 · March 24 at 6:02pm\n\n"
+ "Dragusan Tudorel Elena Elena\n"
+ "Like · Reply · 1 · March 24 at 5:32pm\n\n"
+ "Selegean Nicoleta Porumbei Albi Selegean\n"
+ "Like · Reply · 1 · March 24 at 5:12pm\n\n"
+ "Monika Erzsebet Tamas Szabo\n"
+ "Like · Reply · March 31 at 11:56pm\n\n"
+ "Ana Maria Goia Dan Goia\n"
+ "Like · Reply · March 31 at 7:34pm\n\n"
+ "Alexandru Gulie anka anca\n"
+ "Like · Reply · March 30 at 12:58am\n\n"
+ "Maria Corodescu Popp Costel Dan Corodescu\n"
+ "Like · Reply · March 29 at 11:27pm\n\n"
+ "Anduta Si Maruta Vali Vali\n"
+ "Like · Reply · March 29 at 7:59pm\n\n"
+ "Petruta Mire Ella Trancan Stefania\n"
+ "Like · Reply · March 29 at 9:28am\n\n"
+ "Diana Uricu Razvan Gulie\n"
+ "Like · Reply · March 29 at 3:02am\n\n"
+ "Preda Nicoleta Alina Mary Laurentiu\n"
+ "Like · Reply · March 29 at 12:56am\n\n"
+ "Gabriela Vasilescu Bily Moky\n"
+ "Like · Reply · March 28 at 9:19pm\n\n"
+ "Sinko Bela Norbert Kosa\n"
+ "Like · Reply · March 28 at 8:05pm\n\n"
+ "Ioan Bors Stelian Gheorghe\n"
+ "Like · Reply · March 28 at 7:54pm\n\n"
+ "Moni Elena Eftaliea Mara\n"
+ "Like · Reply · March 28 at 5:46pm\n\n"
+ "Nella Ella Anca Cristina\n"
+ "Like · Reply · March 28 at 3:00pm\n\n"
+ "Dorina Balteanu Bogdan Sabangeanu\n"
+ "Like · Reply · March 28 at 2:59pm\n\n"
+ "Berinde Vladut Vlad Berinde\n"
+ "Like · Reply · March 28 at 1:35pm\n\n"
+ "Iosif Stoian Florentina Flory\n"
+ "Like · Reply · March 28 at 10:17am\n\n"
+ "Iulianna Sabo Denisa Bui\n"
+ "Like · Reply · March 28 at 9:31am\n\n"
+ "Bleotu Macrina Bleotu Gheorghe\n"
+ "Like · Reply · March 28 at 9:10am\n\n"
+ "Ion Cretu Dumitrache Cami Dumitrache\n"
+ "Like · Reply · March 28 at 1:27am\n\n"
+ "Carmen Ionela Radian Nicolae\n"
+ "Like · Reply · March 28 at 1:06am\n\n"
+ "Cristian Sorin Carmen-Ionela Nicolae\n"
+ "Like · Reply · March 28 at 12:54am\n\n"
+ "Cami Dumitrache Dumy Nick\n"
+ "Like · Reply · March 28 at 12:47am\n\n"
+ "Nicolae Cristi Crina Toitan\n"
+ "Like · Reply · March 28 at 12:41am\n\n"
+ "Nutu Marius Carmen Ionela\n"
+ "Like · Reply · March 28 at 12:34am\n\n"
+ "Ile Ilenutza Dan F. Dan\n"
+ "Like · Reply · March 28 at 12:24am\n\n"
+ "Marin Nicolae Ioana Nicolae\n"
+ "Like · Reply · March 28 at 12:21am\n\n"
+ "Ioana Nicolae Marin Nicolae\n"
+ "Like · Reply · March 28 at 12:16am\n\n"
+ "Dumy Nick Cami Dumitrache\n"
+ "Like · Reply · March 28 at 12:11am\n\n"
+ "Carmen Nicolae Radian Nicolae\n"
+ "Like · Reply · March 28 at 12:05am\n\n"
+ "Marina Cioceanu Liviu Moise\n"
+ "Like · Reply · March 28 at 12:04am\n\n"
+ "Ella Ellena Catalin Cozma\n"
+ "Like · Reply · March 27 at 11:59pm\n\n"
+ "Mircea Mircea Geta Geta\n"
+ "Like · Reply · March 27 at 11:52pm\n\n"
+ "Radian Nicolae Carmen-Ionela Nicolae\n"
+ "Like · Reply · March 27 at 11:49pm\n\n"
+ "Emil Hossu Mihaela Nistor\n"
+ "Like · Reply · March 27 at 11:46pm\n\n"
+ "Geta Geta Mircea Mircea\n"
+ "Like · Reply · March 27 at 11:32pm\n\n"
+ "Fish Dan Paula Gabriela\n"
+ "Like · Reply · March 27 at 11:26pm\n\n"
+ "Ungurean Mihai Maria Ungurean\n"
+ "Like · Reply · March 27 at 11:16pm\n\n"
+ "Doina Ana Butman Gheorghiu Paul\n"
+ "Like · Reply · March 27 at 11:09pm\n\n"
+ "Florin Hossu Octavia Durus,\n"
+ "Like · Reply · March 27 at 10:48pm\n\n"
+ "Victor Zota Rose Marya\n"
+ "Like · Reply · March 27 at 10:47pm\n\n"
+ "Ileana Lala Catalin Cozma\n"
+ "Like · Reply · March 27 at 10:40pm\n\n"
+ "Petrina Mani Eva Darla\n"
+ "Like · Reply · March 27 at 10:39pm\n\n"
+ "Tiberiu Petrica Veronik Ungurean\n"
+ "Like · Reply · March 27 at 10:24pm\n\n"
+ "Melinceanu Adrian Tea Ada Hari Ioakeimidis\n"
+ "Like · Reply · March 27 at 10:20pm\n\n"
+ "Tea Ada Hari Ioakeimidis Melinceanu Adrian\n"
+ "Like · Reply · March 27 at 10:18pm\n\n"
+ "Elena Maria Veronik Ungurean\n"
+ "Like · Reply · March 27 at 10:09pm\n\n"
+ "Mara Pia Giorgiana Gio\n"
+ "Like · Reply · March 27 at 10:02pm\n\n"
+ "Ioana Alexandrescu Ion Oprea\n"
+ "Like · Reply · March 27 at 9:56pm\n\n"
+ "Adriana Lautarescu Ungureanu Gabriela\n"
+ "Like · Reply · March 27 at 9:53pm\n\n"
+ "Catalin Cozma Ileana Lala\n"
+ "Like · Reply · March 27 at 9:49pm\n\n"
+ "Steluta Norocoasa Miti Miky\n"
+ "Like · Reply · March 27 at 9:43pm\n\n"
+ "Ion Oprea Ioana Alexandrescu\n"
+ "Like · Reply · March 27 at 9:42pm\n\n"
+ "Skill Zoor Mihai Raliu\n"
+ "Like · Reply · March 27 at 9:39pm\n\n"
+ "Dragos Victor Rose Marya\n"
+ "Like · Reply · March 27 at 9:17pm\n\n"
+ "Ioan C. Ioan Daff Dan\n"
+ "Like · Reply · March 27 at 9:11pm\n\n"
+ "Antonio Bogdan Cioroiu Flori Mimi\n"
+ "Like · Reply · March 27 at 9:11pm\n\n"
+ "Stredie Lydia Mogos Rusalina\n"
+ "Like · Reply · March 27 at 9:07pm\n\n"
+ "Flory Maddy Alex Cîrstocea\n"
+ "Like · Reply · March 27 at 9:04pm\n\n"
+ "Mariana Baroiu Antonio Bogdan\n"
+ "Like · Reply · March 27 at 8:55pm\n\n"
+ "Dany Grasu Raisa Georgiana\n"
+ "Like · Reply · March 27 at 8:48pm\n\n"
+ "Ella Dan Adriana Chereches\n"
+ "Like · Reply · March 27 at 8:41pm\n\n"
+ "Rose Marya Dragos Victor\n"
+ "Like · Reply · March 27 at 8:19pm\n\n"
+ "Veronik Ungurean Tiberiu Petrica\n"
+ "Like · Reply · March 27 at 7:57pm\n\n"
+ "Giorgiana Gio Mara Pia\n"
+ "Like · Reply · March 27 at 7:43pm\n\n"
+ "Maria Ille Mircea Mircea\n"
+ "Like · Reply · March 27 at 7:24pm\n\n"
+ "Ungureanu Gabriela Adriana Lautarescu\n"
+ "Like · Reply · March 27 at 6:40pm\n\n"
+ "Mada Madalynutza Madalina Caty Catyp\n"
+ "Like · Reply · March 27 at 5:56pm\n\n"
+ "Iliana Mihaela Ionut Cretu\n"
+ "Like · Reply · March 27 at 4:59pm · Edited\n\n"
+ "Dragos Zota Marioara Zota\n"
+ "Like · Reply · March 27 at 4:52pm\n\n"
+ "Gela Geluta Stefan Stefan\n"
+ "Like · Reply · March 27 at 4:19pm\n\n"
+ "Mada Madutza Bogdan Bobo\n"
+ "Like · Reply · March 27 at 4:08pm\n\n"
+ "Toni Pre Mona Simu\n"
+ "Like · Reply · March 27 at 4:03pm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}