import Foundation
let pattern = #"^[^\s]+\s[^\s]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Monika Olah Richárd Bai
Like · Reply · March 24 at 4:45pm
Kecskés Dóra Edina Molnar Attila
Like · Reply · March 24 at 4:16pm
Manole Ioana Dana Marinescu
Like · Reply · 2 · March 24 at 5:09pm
Norbert Kosa Sinko Bela
Like · Reply · 1 · March 28 at 9:37am
AsiYe Asy KeJal SeRna
Like · Reply · 1 · March 27 at 4:59pm
Banu Razvan Ana Banu
Like · Reply · 1 · March 26 at 11:40pm
Timeia Denysa Batcau Denisa
Like · Reply · 1 · March 26 at 11:36pm
Cristina Visalon Eugen Comanescu
Like · Reply · 1 · March 26 at 11:21pm
Irina Paun Paula Cristea
Like · Reply · 1 · March 26 at 11:31am
Oneth Ciprian Onet Daniela Carmen
Like · Reply · 1 · March 26 at 12:46am
Sorina Radulescu Tatiana Sorina
Like · Reply · 1 · March 25 at 11:59pm
Neculay Neculayp Caty Catyp
Like · Reply · 1 · March 25 at 4:01pm
Lavinia Popescu Lapadat Liviu
Like · Reply · 1 · March 25 at 12:51pm
Georgeta Pintilie Octavian Pintilie
Like · Reply · 1 · March 25 at 12:30pm
Elena Petrescu Victor Petrescu
Like · Reply · 1 · March 25 at 12:29pm
Doina Paraschiv Petre Paraschiv
Like · Reply · 1 · March 25 at 12:27pm
Adrian Ovreiu Ioana Ovreiu
Like · Reply · 1 · March 25 at 12:26pm
Stan Papusa Crax Prax
Like · Reply · 1 · March 25 at 11:20am
Cornelia Ionescu Sorin Soury
Like · Reply · 1 · March 25 at 10:45am
Daniel Filigeanu Prejmerean Anita
Like · Reply · 1 · March 25 at 10:44am
Nicolae Georgiana Licuta Stan
Like · Reply · 1 · March 25 at 9:23am
Ramo Maryam Gabriela Andrei
Like · Reply · 1 · March 25 at 9:19am
Dana Daniela Lucica Lazar
Like · Reply · 1 · March 25 at 1:11am
Lucica Lazar Paun Dorin Petru
Like · Reply · 1 · March 25 at 12:40am
Cristian MurguleÈ› Narcis Gabriel
Like · Reply · 1 · March 24 at 11:15pm
Rodica Bucur Ionut Richard G
Like · Reply · 1 · March 24 at 10:53pm
Clavi Mpo Elena Lenti
Like · Reply · 1 · March 24 at 9:57pm
Flory Florina Adriana Eco
Like · Reply · 1 · March 24 at 9:01pm
Strempel Henrietta Norbert Ciato
Like · Reply · 1 · March 24 at 8:31pm
Mihai Marele Bfx Bufu
Like · Reply · 1 · March 24 at 7:11pm
Mariana Cioranu Petrica Cioranu
Like · Reply · 1 · March 24 at 6:02pm
Dragusan Tudorel Elena Elena
Like · Reply · 1 · March 24 at 5:32pm
Selegean Nicoleta Porumbei Albi Selegean
Like · Reply · 1 · March 24 at 5:12pm
Monika Erzsebet Tamas Szabo
Like · Reply · March 31 at 11:56pm
Ana Maria Goia Dan Goia
Like · Reply · March 31 at 7:34pm
Alexandru Gulie anka anca
Like · Reply · March 30 at 12:58am
Maria Corodescu Popp Costel Dan Corodescu
Like · Reply · March 29 at 11:27pm
Anduta Si Maruta Vali Vali
Like · Reply · March 29 at 7:59pm
Petruta Mire Ella Trancan Stefania
Like · Reply · March 29 at 9:28am
Diana Uricu Razvan Gulie
Like · Reply · March 29 at 3:02am
Preda Nicoleta Alina Mary Laurentiu
Like · Reply · March 29 at 12:56am
Gabriela Vasilescu Bily Moky
Like · Reply · March 28 at 9:19pm
Sinko Bela Norbert Kosa
Like · Reply · March 28 at 8:05pm
Ioan Bors Stelian Gheorghe
Like · Reply · March 28 at 7:54pm
Moni Elena Eftaliea Mara
Like · Reply · March 28 at 5:46pm
Nella Ella Anca Cristina
Like · Reply · March 28 at 3:00pm
Dorina Balteanu Bogdan Sabangeanu
Like · Reply · March 28 at 2:59pm
Berinde Vladut Vlad Berinde
Like · Reply · March 28 at 1:35pm
Iosif Stoian Florentina Flory
Like · Reply · March 28 at 10:17am
Iulianna Sabo Denisa Bui
Like · Reply · March 28 at 9:31am
Bleotu Macrina Bleotu Gheorghe
Like · Reply · March 28 at 9:10am
Ion Cretu Dumitrache Cami Dumitrache
Like · Reply · March 28 at 1:27am
Carmen Ionela Radian Nicolae
Like · Reply · March 28 at 1:06am
Cristian Sorin Carmen-Ionela Nicolae
Like · Reply · March 28 at 12:54am
Cami Dumitrache Dumy Nick
Like · Reply · March 28 at 12:47am
Nicolae Cristi Crina Toitan
Like · Reply · March 28 at 12:41am
Nutu Marius Carmen Ionela
Like · Reply · March 28 at 12:34am
Ile Ilenutza Dan F. Dan
Like · Reply · March 28 at 12:24am
Marin Nicolae Ioana Nicolae
Like · Reply · March 28 at 12:21am
Ioana Nicolae Marin Nicolae
Like · Reply · March 28 at 12:16am
Dumy Nick Cami Dumitrache
Like · Reply · March 28 at 12:11am
Carmen Nicolae Radian Nicolae
Like · Reply · March 28 at 12:05am
Marina Cioceanu Liviu Moise
Like · Reply · March 28 at 12:04am
Ella Ellena Catalin Cozma
Like · Reply · March 27 at 11:59pm
Mircea Mircea Geta Geta
Like · Reply · March 27 at 11:52pm
Radian Nicolae Carmen-Ionela Nicolae
Like · Reply · March 27 at 11:49pm
Emil Hossu Mihaela Nistor
Like · Reply · March 27 at 11:46pm
Geta Geta Mircea Mircea
Like · Reply · March 27 at 11:32pm
Fish Dan Paula Gabriela
Like · Reply · March 27 at 11:26pm
Ungurean Mihai Maria Ungurean
Like · Reply · March 27 at 11:16pm
Doina Ana Butman Gheorghiu Paul
Like · Reply · March 27 at 11:09pm
Florin Hossu Octavia Durus,
Like · Reply · March 27 at 10:48pm
Victor Zota Rose Marya
Like · Reply · March 27 at 10:47pm
Ileana Lala Catalin Cozma
Like · Reply · March 27 at 10:40pm
Petrina Mani Eva Darla
Like · Reply · March 27 at 10:39pm
Tiberiu Petrica Veronik Ungurean
Like · Reply · March 27 at 10:24pm
Melinceanu Adrian Tea Ada Hari Ioakeimidis
Like · Reply · March 27 at 10:20pm
Tea Ada Hari Ioakeimidis Melinceanu Adrian
Like · Reply · March 27 at 10:18pm
Elena Maria Veronik Ungurean
Like · Reply · March 27 at 10:09pm
Mara Pia Giorgiana Gio
Like · Reply · March 27 at 10:02pm
Ioana Alexandrescu Ion Oprea
Like · Reply · March 27 at 9:56pm
Adriana Lautarescu Ungureanu Gabriela
Like · Reply · March 27 at 9:53pm
Catalin Cozma Ileana Lala
Like · Reply · March 27 at 9:49pm
Steluta Norocoasa Miti Miky
Like · Reply · March 27 at 9:43pm
Ion Oprea Ioana Alexandrescu
Like · Reply · March 27 at 9:42pm
Skill Zoor Mihai Raliu
Like · Reply · March 27 at 9:39pm
Dragos Victor Rose Marya
Like · Reply · March 27 at 9:17pm
Ioan C. Ioan Daff Dan
Like · Reply · March 27 at 9:11pm
Antonio Bogdan Cioroiu Flori Mimi
Like · Reply · March 27 at 9:11pm
Stredie Lydia Mogos Rusalina
Like · Reply · March 27 at 9:07pm
Flory Maddy Alex Cîrstocea
Like · Reply · March 27 at 9:04pm
Mariana Baroiu Antonio Bogdan
Like · Reply · March 27 at 8:55pm
Dany Grasu Raisa Georgiana
Like · Reply · March 27 at 8:48pm
Ella Dan Adriana Chereches
Like · Reply · March 27 at 8:41pm
Rose Marya Dragos Victor
Like · Reply · March 27 at 8:19pm
Veronik Ungurean Tiberiu Petrica
Like · Reply · March 27 at 7:57pm
Giorgiana Gio Mara Pia
Like · Reply · March 27 at 7:43pm
Maria Ille Mircea Mircea
Like · Reply · March 27 at 7:24pm
Ungureanu Gabriela Adriana Lautarescu
Like · Reply · March 27 at 6:40pm
Mada Madalynutza Madalina Caty Catyp
Like · Reply · March 27 at 5:56pm
Iliana Mihaela Ionut Cretu
Like · Reply · March 27 at 4:59pm · Edited
Dragos Zota Marioara Zota
Like · Reply · March 27 at 4:52pm
Gela Geluta Stefan Stefan
Like · Reply · March 27 at 4:19pm
Mada Madutza Bogdan Bobo
Like · Reply · March 27 at 4:08pm
Toni Pre Mona Simu
Like · Reply · March 27 at 4:03pm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)