const regex = /\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\* STATUS (?|(?:\\"([^\\r\\n]+)\\")|(\\S+)|(?:\\{\\d+\\}\\r\\n(.*))) \\(MESSAGES (\\d+) UNSEEN (\\d+)\\)', 'gi')
const str = `* STATUS "INBOX.&jspOIQ-" (MESSAGES 2 UNSEEN 1)
* STATUS "&jspOIQ-" (MESSAGES 3 UNSEEN 1)
* STATUS {14}
INBOX."quotes" (MESSAGES 6 UNSEEN 1)
* STATUS {8}
"quotes" (MESSAGES 10 UNSEEN 1)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}