// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)"#).unwrap();
let string = "* STATUS \"INBOX.&jspOIQ-\" (MESSAGES 2 UNSEEN 1)
* STATUS \"&jspOIQ-\" (MESSAGES 3 UNSEEN 1)
* STATUS {14}
INBOX.\"quotes\" (MESSAGES 6 UNSEEN 1)
* STATUS {8}
\"quotes\" (MESSAGES 10 UNSEEN 1)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}