import re
regex = re.compile(r"\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)", flags=re.IGNORECASE)
test_str = ("* STATUS \"INBOX.&jspOIQ-\" (MESSAGES 2 UNSEEN 1)\n\n"
"* STATUS \"&jspOIQ-\" (MESSAGES 3 UNSEEN 1)\n\n"
"* STATUS {14}\n"
"INBOX.\"quotes\" (MESSAGES 6 UNSEEN 1)\n\n"
"* STATUS {8}\n"
"\"quotes\" (MESSAGES 10 UNSEEN 1)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")