const regex = /^\>(.*?)(?=\>|\n\n)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\>(.*?)(?=\\>|\\n\\n)', 'gms')
const str = `> this is a match
> so is this, but should be in the same match as above
> this should be a seperate match > this is nothing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}