re = /^\>(.*?)(?=\>|\n\n)/m
str = '> this is a match
> so is this, but should be in the same match as above
> this should be a seperate match > this is nothing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end