import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^(https?://)?((www\.)?t(elegram)?\.(dog|me)/((?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]|[\w\+-]{13,17})|(?![_\d])(?!.*__)(?!.*_$)\w{4,}[a-z\d]\.(t(elegram)?\.(dog|me)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://t.me/+-k0L3asdxMc2Mjc8
https://t.me/telegram
telegram.t.me
telegram.telegram.me
t.me/telegram
https://www.t.me/+-k0L3asdxMc2Mjc8
telegram.t.me
tel_egram.t.me
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)