const regex = /^(?![A-Za-z]\d?$)[a-zA-Z]+\d*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![A-Za-z]\\d?$)[a-zA-Z]+\\d*$', 'gm')
const str = `tt
tt2
test
a11
t2
t
1
t1t`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}