import re
regex = re.compile(r"^(?![A-Za-z]\d?$)[a-zA-Z]+\d*$", flags=re.MULTILINE)
test_str = ("tt\n"
"tt2\n"
"test\n"
"a11\n\n"
"t2\n"
"t\n"
"1\n"
"t1t")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")