const regex = /(?<=\s)\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)\\s', 'g')
const str = `This is my text.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);