$re = '/(?<=\s)\s/';
$str = 'This is my text.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;