import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?P<match_1>chest|test|west|nest)(?:\\b\\s+(?P<match_2>mike|bike|like|pike)(?:\\b\\s+(?P<match_3>hay|day|may|say)\\b)?)?";
final String string = "zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz\n"
+ "aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa\n"
+ "ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}