const regex = new RegExp('\\b(?P<match_1>chest|test|west|nest)(?:\\b\\s+(?P<match_2>mike|bike|like|pike)(?:\\b\\s+(?P<match_3>hay|day|may|say)\\b)?)?', 'gm')
const str = `zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz
aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa
ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}