$re = '/\b(?P<match_1>chest|test|west|nest)(?:\b\s+(?P<match_2>mike|bike|like|pike)(?:\b\s+(?P<match_3>hay|day|may|say)\b)?)?/m';
$str = 'zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz
aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa
ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);