import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\[\\[(?!(assets|Bücher|Dokumente|Dokumenttyp|epsilon_notes|kontakte|literatur|Proj|Test|Wissen|WV)(?:[\\w_]*)\\/)(?<firstlevelfolder>[^\\/\\|#\\]]*\\/)?(?<bildpfad>[^\\|\\\\\\]#]+)(\\\\\\||\\||#)*(?<bildattribut>[^\\]]*)\\]\\]";
final String string = "Link zum Bild:\n"
+ "![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg]]\n\n"
+ "![[subfolder/image.png|100x100]]\n"
+ "![[subfolder/sub2/image.png|100x100]]\n"
+ "![[../../ima/ge.png|100x100]]\n"
+ "![[Projekte/image.png|100x100]]\n"
+ "![[Projekte/image.Png|100x100]]\n"
+ " \n"
+ "[[assets/MiSZ 2T.pdf]]\n"
+ "[[assets2/MiSZ 2T.pdf]]\n"
+ "![[Projekte/Mikroskop/Leica, Wild/Product Guide for Stereomicroscopes. Living up to Life.pdf]]\n"
+ "![[BA_GSZ 2_GSZ 2T.pdf#page=7]]\n"
+ "![[BA_GSZ 2_GSZ 2T.pdf]]\n\n"
+ "Beispiel-tabelle:\n"
+ "Caption1 | Caption2 |\n"
+ "---|---|\n"
+ "Content1 text | Link innerhalb Tabelle mit Attributen\n"
+ "![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\\|300]] |\n"
+ "vorerst letzte Zeile | Text Text Text |\n\n"
+ "![[Projekte/Mikroskop/_resources/f04ae6b6a924e20e761dce25603b3bd8.jpg\\|200]]";
final String subst = "[<span style=\"color:red\">CompProc_LinkToFileNonAbsoluteLink:** </span> <span style=\"background-color: #ff9898; color:blue\">**${firstlevelfolder}**${bildpfad}</span>](${firstlevelfolder}${bildpfad})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}